MacBook Pro vs Soniq TV vs HDMI adaptor

Most things on the Mac are purportedly easy since many of the un-ncessary options are removed.  This is great until you want to non-conform (read, use some hardware that is old, cheap, or just un-ordinary).

Trying to get HDMI with sound working through a Kanex iAdapt v2 mini display port, proved to be tricky due to the lack of options and just some wierdness of HDMI in general.

The other player in this whole mess was my cheopo year old 32″ Soniq QSL 322 LCD TV5. ┬áIts been great so far, I’ve used HDMI connections to a couple of PVR units without problem.

When I plugged everything on the Mac though, even though it automatically recognised the display, the sound would still come through the laptop speakers. ┬áTurns out thats a Sound System Preference Panel option to switch that. (option + F11)´╗┐´╗┐´╗┐´╗┐

Quick win right? Wrong, still no sound!  Rebooting, changing the order things were switched on.  Turning the volume up on the TV didnt do anything.  Also, while your Mac sound output is HDMI, the volume controls (F11/F12) dont do squat!

Then I tried a different tack.

I rebooted into Bootcamp (win 7 64bit) & the sound was working fine. There was a bit of a hiss in the background, and if no sound for a few seconds, the sound would switch off for a while – no hiss – until I played something again. ┬áThere would be a 1/2 sec delay waking up from the silence but otherwise ok for watching movies and music. ┬áI later learnt from Kanex support that this is normal part of HDCP (the handshake that your devices do with each other to make sure they aren’t pirates. aarrrrrrr!)

When I rebooted back into OS X, the sound continued to work fine.

However once I put my computer to sleep and rewoke it, whilst leaving everything plugged in, the sound on the TV stopped working.

I recall reading on the apple support forums that there was some issue to do with HDMI handshaking and turning the devices on and off in a different order would fix the problem. It would appear for me that if the TV is on HDMI input first, then the mac is booted up sound can work.

I thought that was good enough but I found I could do one better and fix the sound whilst the Mac was already on.

I also read about a MIDI control panel that could be used to change how the digital output is sent via HDMI. Eventually I found it in Applications->Utilities-> Audio Midi Setup (not System Preferences).

I found that the HDMI ‘LCD TV’ device was at Format 96000.0 Hz. When I changed this down to 48000.0Hz then I could hear a sound through my TV speakers again. (Another way to get sound working, was press ‘Configure Speakers…’ button on the same screen and do a speaker test which also triggered the TV sound again)

So after changing down to 44100, the sound seems to work consistently on each plugin.  And if I ever do loose the sound again, I can get it back through here without needing to reboot my mac, tv, etc.